We have continued to closely monitor operations throughout the weekend and can confirm that system performance has remained stable. Job processing has returned to and is continuing at normal levels, with no further issues observed. We will maintain enhanced monitoring as a precaution, but at this time the incident is considered resolved.
Posted Jul 19, 2026 - 13:13 UTC
Monitoring
We have deployed corrective fixes to address the issue affecting certain VM and OneDrive backups and are actively monitoring system performance to ensure service stability and continued improvement. While backup performance is recovering, some customers may still experience intermittent delays or longer-than-normal backup durations as the environment stabilizes.
Our teams remain closely engaged and are monitoring the effectiveness of these changes while continuing to validate system health across impacted services. We appreciate your patience and understanding as we work to fully restore normal service levels and will provide additional updates as needed.
Posted Jul 17, 2026 - 15:11 UTC
This incident affected: Office 365 (Germany West Central) and VM & Kubernetes (Germany West Central).