The issue has been resolved, and backups are running as expected. We are closely monitoring the ring to ensure continued stability.
Posted Jun 14, 2025 - 11:32 UTC
Investigating
We are currently addressing a performance issue affecting job execution, causing some jobs to remain in a waiting state. Our team is actively working to resolve the issue and restore normal operations as soon as possible
Posted Jun 14, 2025 - 10:18 UTC
This incident affected: Office 365 (Germany West Central) and VM & Kubernetes (Germany West Central).